Přeskočit na obsah Přeskočit na hlavní navigaci Přeskočit na zápatí (patičku)

Všechny

Tato záložka je dostupná pouze pokud je u licence aktivní modul NMM.

Přehled přidaných routerů nebo AP a k nim přímo připojených zařízení. Provádí se zde monitoring, správa a konfigurace všech routerů, headendů, AP, připojených switchů a dalších připojených zařízení.

Přehled

MikroTik

Přehled zaevidovaného routeru MikroTik
Přehled zaevidovaného routeru MikroTik

Hlavní menu

První položkou v hlavním menu zaevidovaného routeru MikroTik je možnost sbalit () nebo rozbalit () jeho podrobnosti a detaily.

Akce
  • Reboot routeru MikroTik – možnost vybraný router restartovat. POZOR – reboot je proveden ihned po stisknutí na toto tlačítko! Sledovat průběh rebootu je možné v zobrazeném modal okně.
Průběh rebootu routeru MikroTik
Průběh rebootu routeru MikroTik
  • Update konfigurace routeru – možnost na vybraném routeru updatovat konfiguraci ze systému (změny v nastavení). POZOR – update konfigurace je proveden ihned po stisknutí na toto tlačítko! Sledovat průběh updatu konfigurace je možné v zobrazeném modal okně. Update konfigurace routeru je možné provést i zkrácenou volbou (sekce Tlačítka).
Průběh updatu konfigurace routeru MikroTik
Průběh updatu konfigurace routeru MikroTik
  • Nouzový režim na routeru – aktivací nouzového režimu na vybraném routeru můžete nastavit procentuální snížení/zvýšení rychlosti u klientů. Nouzový režim lze využít např. při výpadku páteřní linky, kdy je provoz přesměrován přes pomalejší linku a je potřeba dočasně snížit rychlost, aby spoj byl schopný provoz zvládnout.
    • Zahrnout závislé routery – možnost nastavit nouzový režim i na závislých routerech (funguje pouze pro nastavené Nagios závislosti)
    • Vypnout řízení rychlosti – pokud je u routeru použita (nastavena) metoda shapování Simple Queues, je k dispozici i toto nastavení vypnutí omezení rychlosti. Více informací v Simple Queues.
Nastavení nouzového režimu
Nastavení nouzového režimu
Přepnutí na normální provoz
Přepnutí na normální provoz

Pokud byl na routeru aktivován nouzový režim, objeví se u něj informace:

Zapnutý nouzový režim na routeru
Zapnutý nouzový režim na routeru
  • Otestovat spojení na router – možnost otestovat spojení (ping, SNMP, SSH, API/API-SSL). Výsledky a průběh testu je dostupný v zobrazeném modal okně.
  • Odstranit neaktivní síťová rozhraní – možnost smazat u vybraného routeru v přehledu neaktivní síťová rozhraní
Nastavení
  • Queue trees – v případě použití tarifu ve službě internet s agregací 1:1 (nebo nastavením individuální rychlosti bez tarifu) je možné službu internet u klienta zařadit do speciální QT, kterou je možné touto funkcí vytvořit. Na Mikrotiku je nutné tuto QT vytvořit ručně (název musí odpovídat zde vytvořené).
Nastavení speciální queue v ISPA
Nastavení speciální queue v ISPA
Pojmenování a nastavení QT (ISPA vs. MikroTik)
Pojmenování a nastavení QT (ISPA vs. MikroTik)
Propisování parametrů QT ze služby internet do zařízení MikroTik
Propisování parametrů QT ze služby internet do zařízení MikroTik

Přidat speciální Queue Tree je možné přes utilitu WinBox (GUI) nebo terminal (CLI).

Základní příkazy pro ROS CLI (příklad):

/queue tree add name=TEST_SPECIAL1 parent=global
/queue tree add name=TEST_SPECIAL_IN parent=global
/queue tree add name=TEST_SPECIAL_OUT parent=global
Příklad služeb (individuální rychlost) a propsaných speciálních QT pravidel
Příklad služeb (individuální rychlost) a propsaných speciálních QT pravidel
  • Přípojné body – možnost nadefinovat k routeru přípojné body a na nich dostupný typ služeb
  • IP aliasy – možnost povolit provoz i na další nadefinované IP adresy vybraného routeru. Přidat nový IP alias je možné tlačítkem Přidat nový IP alias (). Nadefinovaná IP adresa se povolí ve firewallu.
Nastavení IP aliasu pro vybraný router
Nastavení IP aliasu pro vybraný router

Přidat

  • Přidat síťové rozhraní

Grafy

Související

  • Zálohy konfigurace routerů

Tlačítka

U routeru typu MikroTik jsou zde k dispozici tři funkční tlačítka (zkrácené volby).

  • Update konfigurace routeru – možnost na vybraném routeru updatovat konfiguraci ze systému (změny v nastavení). POZOR – update konfigurace je proveden ihned po stisknutí na toto tlačítko! Sledovat průběh updatu konfigurace je možné v zobrazeném modal okně.
  • Otestovat spojení na router – možnost otestovat spojení (ping, SNMP, SSH, API/API-SSL). Výsledky a průběh testu je dostupný v zobrazeném modal okně.
  • Zobrazit statistiky pingu na router – možnost zobrazit stránku s grafy pingu vybraného routeru (den, týden, měsíc, rok).
Test spojení
Test spojení
Zobrazení grafu pingu
Zobrazení grafu pingu

Základní info

Stav komunikace

K dispozici jsou tři ikony zobrazující stav komunikace – API-SSL (API), SSH, SNMP

  • API / API-SSL
    • – API-SSL nebo API není aktivní (zapnuté)
    • / – API-SSL nebo API je na zařízení aktivní (zapnuté)
    • / – API-SSL nebo API je aktivní, ale nastal nějaký problém (error, chyba v komunikaci)
  • SSH
    • – SSH není aktivní (zapnuté) nebo nejsou vyplněné údaje
    • – SSH je na zařízení aktivní (zapnuté)
    • – SSH je na zařízení aktivní (zapnuté). Pro plnohodnotnou práci s routerem je však potřeba aktivovat API-SSL (API)
    • – SSH je aktivní, ale nastal problém (error). Ověřte nastavení na zařízení nebo nastavení firewallu
  • SNMP
    • – SNMP nejsou vyplněné údaje
    • – SNMP je aktivní a funkční
    • – SNMP je aktivní (vyplněné údaje), ale nastal problém (error). Ověřte nastavení na zařízení nebo nastavení firewallu

Stav funkcí

Síťová rozhraní

Další sekce

Pokud bylo některé z pravidel mangle ručně upraveno (přímo na routeru např. disabled), zobrazí se u dotčeného routeru informace o ruční úpravě.

Zapnuté oznamování výpadků a informace o ruční úpravě v sekci mangle
Zapnuté oznamování výpadků a informace o ruční úpravě v sekci mangle

Přidat / Upravit

Rozdělení dle typů zařízení a dostupných parametrů a funkcí.

MikroTik

Nastavení zařízení (routeru) typu MikroTik.

Záložky

Obecné informace

Možnost zadat základní obecné informace k zařízení/routeru typu MikroTik.

  • Jméno routeru (vyžadované) – název routeru
  • POP – POP na kterém je zařízení zaevidováno (fyzicky leží)
  • Lokalita – lokalita ve které se router nachází. Pokud je vybrán POP (viz výše), tak toto pole není k dispozici = převezme se z POPu
  • Skupina – skupina zařízení
  • GPS – GPS souřadnice umístění zařízení. Pokud je vybrán POP (viz výše), tak toto pole není k dispozici = převezme se z POPu
  • Adresa – adresa umístění routeru. Pokud je vybrán POP (viz výše), tak toto pole není k dispozici = převezme se z POPu
  • Popis – vlastní popis
  • Interní ID – možnost zadat vlastní interní ID pro zařízení

Nadřazené zařízení pro Nagios – pokud využíváte původní řešení pro notifikaci výpadků, je potřeba zde nastavit závislost.

  • Router – nadřazený router
  • Zařízení – nadřazené zařízení
  • Oznamovat výpadky – možnost zvolit skupinu kontaktů pro notifikování (NetMonitor)
  • Mapa
  • IP adresa routeru (vyžadované) – IP adresa routeru
  • Typ routeru – zvolený typ routeru (MikroTik). Dle zvoleného typu routeru jsou k dispozici další parametry/funkce.
  • QoS provádět na / Závislý na – nastavení QOS (lokálně, neprovádět QOS nebo možnost vybrat zařízení na kterém se bude shaping provádět = pouze routery typu MikroTik)
  • Typ shapingu – simple-queue nebo queue tree (výchozí)
  • Typ fronty – nastavení typu fronty (více info MikroTik WIKI)
  • Queue tree type – (k dispozici pouze v editaci u routeru s ROS < v6) pokud je aktivní typ shapingu queue tree, je k dispozici nastavení této možnosti (global-in, global-out). global-in, global-out a global-total jsou nahrazeny pouze global (ROS > v5)
  • Maximální download – možnost pro evidenci zadat maximální download
  • Maximální upload – možnost pro evidenci zadat maximální upload
  • Router je aktivní – zda-li je router aktivní (připojen)
  • Deaktivovat zálohování – možnost deaktivovat zálohování
  • Pouze monitorování routeru – zda-li chcete router pouze monitorovat (bez řízení). Pokud je tato možnost aktivní, tak systém do routeru nenahrává žádnou konfiguraci ani její změny. Dochází pouze k pasivnímu vyčítání dat a v přehledu jsou tato zařízení označena šedou barvou.
Barevné označení (šedé) pouze monitorovaného routeru (Mikrotik)
Barevné označení (šedé) pouze monitorovaného routeru (Mikrotik)
  • Používat API – možnost využít API/API-SSL komunikaci s routerem
    • API port – port pro API (default: API–8728, API-SSL–8729)
    • Používat API-SSL (doporučeno) – zda-li používat místo původního API zabezpečenou verzi API-SSL
  • Používat DHCP – pokud je zadaná IP a MAC adresa klienta nebo konc. zařízení ve službě internet a u služby je vybrán router s tímto nastavením, je systém schopen do MikroTiku propisovat DHCP leases (/ip dhcp-server lease). Při každém updatu routeru se před nahrátím DHCP leases provede vymazání dynamicky přiřazených DHCP leases.
    DHCP server musí být na routeru MikroTik správně nakonfigurován!
Zapsané DHCP leases
Zapsané DHCP leases
  • Syslog monitor – zapnutí LOG monitoru z MikroTiku. Zobrazení uchovaného syslogu vybraného routeru v (Hardware –> Syslog).
  • Aplikovat pravidla firewallu – jestli se mají pravidla FW aplikovat lokálně (na editovaný router) nebo na jiném. Podrobnější informace o nastavení viz MikroTik – Firewall.
    • Aplikovat defaultní firewall – pokud je vybrán jiný router (ne lokálně), tak je možné zapsat alespoň defaultní pravidla. Podrobnější informace o nastavení viz MikroTik – Firewall.
  • Neaplikovat lokálně MANGLE, FILTER a NAT pravidla – na lokálně (editovaný router) se neaplikují MANGLE, FILTER a NAT pravidla. Nelze použít s nastavením výše – Aplikovat pravidla firewallu. Vzájemně se vyruší. Upozornění při uložení. Podrobnější informace o nastavení viz MikroTik – Firewall.
  • Přesný typ – zvolení přesného typu dle kategorie router (Hardware –> Nastavení –> Typy zařízení)
  • SNMP community – nastavené community na zařízení
  • SNMP port – port pro vyčítání přes SNMP
  • Verze SNMP – verze SNMP protokolu (1,2)
  • Sériové vyčítání SNMP – některá zařízení neumí hromadné vyčtení OID. Touto metodou lze zapnout sériové vyčítání hodnot např. do grafů.
  • SNMP šablony – možnost vybrat připravenou SNMP šablonu
  • SSH user – uživatel k SSH
  • SSH heslo – heslo k SSH
  • SSH port – port pro připojení k SSH
  • Port webového rozhraní – port pro webovou správu zařízení
  • MAC filter – zapisuje se do pravidla ve filter (src-address služby klienta) navíc src-mac
  • Používat wireless MAC filter – zapisuje se MAC filter (MikroTik – Wireless / Access List) – zařízení připojené k routeru, služby klientů, servisní MAC (Nastavení –> Administrátoři –> Servisní MAC)
  • Upravit extra MAC na routeru – speciální (ručně zadané) MAC adresy do MAC filteru výše. Pokud není aktivní nastavení Používat wireless MAC filter, tak se zadané extra MAC do wireless konfigurace routeru nepropisují (v přehledu routerů je funkce neaktivní – ).
  • Aktivovat RADIUS – zda-li si přejete aktivovat u zařízení ověřování přes radius
    • Heslo pro komunikaci s RADIUSem – pokud je RADIUS aktivní (viz možnost výše), tak je zde možné zadat heslo pro komunikaci
  • Přihlášení techniků do MikroTiků s RADIUSem – zapnout/vypnout přihlášení techniků do MikroTiků přes RADIUS server
  • Restart routeru – zapnout periodické restartování routeru
    • Hodiny / Minuty – časový údaj v hodinách / minutách
    • Periodicita – jak často router restartovat (denně, týdně, měsíčně)
Extra MAC v konfiguraci Access Listu na MikroTiku
Extra MAC v konfiguraci Access Listu na MikroTiku
Firewall

Možnost zadat specifické nastavení pro vybraný router.

  • Úvodní FW – na routeru – možnost zadat pravidla na začátek FW na konkrétním vybraném routeru. Více informací v MikroTik – Firewall
  • Závěrečný FW – na routeru – možnost zadat pravidla na konec FW na konkrétním vybraném routeru. Více informací v MikroTik – Firewall
  • Úvodní mangle
  • Závěrečný mangle
  • Úvodní FW NAT – na routeru
  • Závěrečný FW NAT – na routeru
Address list

Vlastní address list pro vybraný router.

  • Address List – možnost definovat vlastní address-list na konkrétním vybraném routeru. Kliknutím na zelenou sekci je možné zobrazit výchozí nastavení pro všechny routery MikroTik z klíče mikrotik_default_address_list (Nastavení –> Syst. nastavení –> MikroTik).
/ip firewall address-list add list=router_list address=1.2.3.4/32 comment="router_address_list"
Definování vlastního address-listu na vybraném routeru
Definování vlastního address-listu na vybraném routeru

MikroTik redundant

UPOZORNĚNÍ:
Samotná konfigurace routeru se neduplikuje (např. nastavení bridge, DHCP serverů atp). K tomu je možné využít např. obnovení zálohy master routeru.

Pokud je typ routeru nastaven na – Mikrotik – redundant, tak je možné v poli Master router vybrat „rodičovský“ router, podle kterého se bude konfigurace kopírovat.

  • Master router – do redundantního routeru se budou nahrávat stejná pravidla ze systému ISPadmin, jako jsou na zvoleném Master routeru. Bude tak vždy k dispozici záložní router s aktuální konfigurací, který bude možné použít, pokud to bude nutné.

Juniper

Možnost zadat základní obecné informace k zařízení/routeru typu Juniper.

Záložky

Obecné informace
  • Jméno routeru (vyžadované) – název routeru
  • POP – POP na kterém je zařízení zaevidováno (fyzicky leží)
  • Lokalita – lokalita ve které se router nachází. Pokud je vybrán POP (viz výše), tak toto pole není k dispozici = převezme se z POPu
  • Skupina – skupina zařízení
  • GPS – GPS souřadnice umístění zařízení. Pokud je vybrán POP (viz výše), tak toto pole není k dispozici = převezme se z POPu
  • Adresa – adresa umístění routeru. Pokud je vybrán POP (viz výše), tak toto pole není k dispozici = převezme se z POPu
  • Popis – vlastní popis
  • Interní ID – možnost zadat vlastní interní ID pro zařízení

Nadřazené zařízení pro Nagios – pokud využíváte původní řešení pro notifikaci výpadků, je potřeba zde nastavit závislost.

  • Router – nadřazený router
  • Zařízení – nadřazené zařízení
  • Oznamovat výpadky – možnost zvolit skupinu kontaktů pro notifikování (NetMonitor)
  • IP adresa routeru (vyžadované) – IP adresa routeru
  • Typ routeru – zvolený typ routeru (Juniper).Dle zvoleného typu routeru jsou k dispozici další parametry/funkce.
  • QoS provádět na / Závislý na
  • Maximální download – možnost pro evidenci zadat maximální download
  • Maximální upload – možnost pro evidenci zadat maximální upload
  • Router je aktivní – zda-li je router aktivní (připojen)
  • Deaktivovat zálohování – možnost deaktivovat zálohování
  • Pouze monitorování routeru – zda-li chcete router pouze monitorovat (bez řízení)
  • Používat API – možnost zapnout na zařízení API
    • Uživatelské jméno – přihl. jméno do API
    • Heslo – heslo do API
    • API port – port pro API
  • Přesný typ – zvolení přesného typu
  • SNMP community – nastavené community na zařízení
  • SNMP port – port pro vyčítání přes SNMP
  • Verze SNMP – verze SNMP protokolu (1,2)
  • Sériové vyčítání SNMP – některá zařízení neumí hromadné vyčtení OID. Touto metodou lze zapnout sériové vyčítání hodnot např. do grafů.
  • SNMP šablony – možnost vybrat připravenou SNMP šablonu
  • Port webového rozhraní – port pro webovou správu zařízení
  • Aktivovat RADIUS – zda-li si přejete aktivovat u zařízení ověřování přes radius
    • Heslo pro komunikaci s RADIUSem – pokud je RADIUS aktivní (viz možnost výše), tak je zde možné zadat heslo pro komunikaci